Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Error 751 bei ExecuteSQLCommand Win7-32/64
15.06.2012, 10:07
Beitrag: #1
Error 751 bei ExecuteSQLCommand Win7-32/64
Bekomme selbst im VEE-Pro 9.3 Datenbank-Beispielprogramm (z.B. Update.VEE), ständig die Fehlermeldung "Error 751". Programm läuft auf einem Win7-64, wobei ich in meiner maximalen Verzweiflung bereits folgendes nachinstalliert hab:
mysql-connector-odbc-3.51.30-winx64
SQLEXPR32_x86_DEU
dotNetFx40_Full_x86_x64

Das Ganze lief schon mal auf einem Win7-32

Was benötige ich denn noch???

Gruß Wolfgang
Diese Nachricht in einer Antwort zitieren
18.06.2012, 10:18 (Dieser Beitrag wurde zuletzt bearbeitet: 18.06.2012 10:21 von detlef.)
Beitrag: #2
RE: Error 751 bei ExecuteSQLCommand Win7-32/64
Kann nicht direkt weiterhelfen, aber gib mal error 751 in der Vee-Hilfe ein. Da gibt es dann ein paar Tips.
Aber generell duerftest du in der 32 / 64 Bit Falle haengen.

Ich wuerde erst mal alle Sachen in 32 Bit installieren- die sollten auch unter einem 64 bit System laufen ( WoW ).
Da gibt es viele Infos auf der SQL Microsoft Seite....

Wenn alles nix hilft, lass mal den Processexplorer und die Dependencies laufen, um zu sehen, welche Dateien benoetigt werden.
Bei den Sysinternals- da gibt es ein Programm, was das macht -dependencies.exe oder so aehnlich... genau weiss ich gerade nicht.

-Ah, gegoogelt: depends.exe bei Dependency Walker suchen...
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
20.06.2012, 12:49
Beitrag: #3
RE: Error 751 bei ExecuteSQLCommand Win7-32/64
Vielen Dank,
die VEE-Hilfe und der DependencyWalker haben mich nicht weitergebracht!
Diverse Dinge hab ich hin- und her-installiert -> erfolglos (32Bit-64Bit läßt sich nicht immer wählen)!
Im Vee-Programm die .NET Assembly references auf aktuelleres Framework einzustellen, lehnte Vee auch ab! Selbst bei Aufruf als Systemadministrator!

Aber: Konnte das Problem lösen:

1) Hab einmal das Programm Access64Registry.exe (im VEE-Programmverzeichnis) aufgerufen (keine Rückmeldung, und keine Ahnung, ob es überhaupt was genützt hat)
2) Aufruf von VEE.EXE als Systemadministrator, was mich zu den folgenden Schritten bewegt hat:
3) Kopie der Vee-Beispieldatenbank (NorthWindForModify.mdb) auf die Festplatte (Benutzerberechtigungen für User und Administrator auf vollen Zugriff geändert)
4) Kopie der Datenbank-Beispielprogramme ebenfalls auf die Festplatte (weil vermutlich im Verzeichnis C:\Program Files (x86)\Agilent\VEE Pro 9.3 die Rechte auch begrenzt sind)

jetzt ging alles, was ich zu diesem Zeitpunkt brauchte, hab aber:

5) Die Datenbank auf Access2007-Format geändert (die Rechte ließen sich da nicht mehr einstellen)
6) Die Beispielprogramme auf Init Access2007 angepaßt

... was soll ich sagen: Es tut!!!

Vielen Dank für die Bemühungen!!!
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Gehe zu:




Partnerforen: LabVIEWForum.de| DIAdem-Forum.de| Machine-Vision-Forum.de| goMatlab.de| VEEforum.de