Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Geräteansteuerung über TCPIP
22.11.2007, 14:51
Beitrag: #1
Geräteansteuerung über TCPIP
Hallo,

ich habe folgendes Problem. Leihweise wurde mir ein Oszi zur Verfügung gestellt, welches ich über TCPIP ansprechen möchte. Im Instrument Explorer von Agilent wird das Gerät erkannt, so dass die Verbindung schonmal hergestellt ist, und die Kommunikation prinzipiell möglich ist. Wenn ich nun das Oszi in einem Vee-Programm mit dem Instrument-Manager hinzufügen will, findet er dieses nicht. Manuelles hinzufügen mit anschließenden durchsuchen des TCPIP-Interfaces ergibt die Meldung "The Interface does not exist", obwohl außerhalb von Vee das Gerät an dieser Schnittstelle erkannt wird. Weiß jemand eine Lösung??

Ich nutze Vee 8.0, IO Library 14.2 und Windows 2000.

Danke und Grüße Sascha
Diese Nachricht in einer Antwort zitieren
23.11.2007, 13:38
Beitrag: #2
 
Dumme Frage vielleicht, aber welches Interface hast du ausgesucht, und welche stehen dir zur Verfuegung ??
Zeig mal einen Screenshot.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
26.11.2007, 19:01
Beitrag: #3
 
Moin auch,

die Verfahrensweise über TCPIP würde mich auch interessieren, zumal ich vorhabe, zwei Rechner miteinander über ein Netzwerk zu verbinden.
Dabei dient der eine Rechner als Aufnehmer der Messwerte ( kommen über RS-232) und gibt die Messwerte konstant weiter auf das Netzwerk.
Zweiter Rechner empfängt über Netzwerk und stellt dar, loggt die empfangenen Daten.

Allerdings habe ich mir noch keinerlei Gedanken gemacht ...... .

Beste Grüße,
Günter
Diese Nachricht in einer Antwort zitieren
28.11.2007, 11:44
Beitrag: #4
 
Oh, da gibt es verschiedene Moeglichkeiten.
So ad hoc wuerd ich ein Windows-Netzwerk an beiden Rechnern einrichten, eine Dateifreigabe machen, die Daten in den Ordner schreiben und dann mit dem anderen Rechner auf den Ordner und die Datei zugreifen...ist im Prinzip egal, wo dann die Datei auf welchem Rechner ist.

Geht aber auch anders von VEE Programm zu VEE Programm, da gab es ein Beispiel....
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
29.11.2007, 12:08
Beitrag: #5
 
Wie der Teufel so will, gab es gerade eine aehnliche Frage in der VRF.
Mittels commandline kann man auf Netzwerkresourcen zugreifen:


> You can mount a network drive share using a command like:
>
net use w: \\computer.domain.name\directory /user:domain\login password
>

> If you use an execute program object running a command like cmd /c
> line_from_above > file_to_to_store_results, you could read the file
> where you stored the results to see if it worked.
>

once you have command line up ( execute program ) you have lots of other options also:

net use will list the open shares so you can use this to see
if you need to do the mount in the first place

net use \\computer.domain.name\directory /user:domain\login password
will access the share without having to mess
with drive letters

and so on

regards

Stan
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
04.12.2007, 16:59
Beitrag: #6
 
mmmh,
wie ist das nun zu deuten? Der Begriff "VRF" sagt mir so direkt nichts außer das hier: Virtual Routing and Forwarding.
Liege ich da falsch?

Aber egal, es ist noch nicht sooooo akut.

Dafür aber ein anderes lustiges Problem.
Dies wird aber an anderer Stelle behandelt.


Dank und Gruß,
Günter
Diese Nachricht in einer Antwort zitieren
04.12.2007, 17:34
Beitrag: #7
 
VRF ist die Mailingliste fuer VEE von Agilent....der VEE reflector...
findet sich in dem Menue Help.
ist allerdings english, but seems to be no problem for most of us ;-)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
05.12.2007, 18:24
Beitrag: #8
 
So, hab jetzt auch mal Geraete mit LAN -Ansteuerung ..und hatte auch Probleme, weil es am Anfang nicht so ging wie erwartet....

Abhilfe war:
1. Habe die IO config von VEE geloescht.
2. Habe sichergestellt, dass die Firewall nicht blockt
3. Habe dann Lan-Kabel eingestoepselt, dann IOlib14.2 IOcontrol gestartet.
Da hat er das Geraet nicht automatisch gefunden.
4. Danach hab ich das Geraet manuel eingefuegt, und alle Einstellungen automatisch suchen lassen.
5. Dann aus ioconfig raus und VEE gestartet.
6. Im IOmanager hab ich die Geraete suchen lassen...und voila, es war da unter TCPIP...
7. Dann das Geraet angeklickt und mit LOad Sample das richtige Beispielrogramm geladen......

Wenn alles so einfach waere ( am liebsten beim ersten Versuchen ...)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
11.04.2010, 08:39
Beitrag: #9
RE: Geräteansteuerung über TCPIP
Mittlerweile gibt es ja die IOlibs 15.51, dort sind einige Verbesserungen bezueglich der Netzwerkmoeglichkeiten eingepflegt.
Dort sollten dann Probleme , wie zuvor vorgekommen, nicht mehr auftreten.
Also, aktuelle Versionen: VEE 9.2 und IOLIB 15.5x, beides WIndows 7 clean, und die IOlib mit 64 bit native support.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Gehe zu:




Partnerforen: LabVIEWForum.de| DIAdem-Forum.de| Machine-Vision-Forum.de| goMatlab.de| VEEforum.de