Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Zwei Agilent U2355A über IVI-COM Treiber?
26.11.2010, 10:13
Beitrag: #1
Question Zwei Agilent U2355A über IVI-COM Treiber?
Hallo Vee Forum,
ich möchte gerne innerhalb eines Vee Programms Daten von zwei Agilent U2355A DAQ´s erfassen.
Ich benutze diese Hardware seit mehreren Jahren, jedoch muss ich nun erstmals zwei dieser Geräte über den IVI-COM Treiber ansprechen bzw. die Instanz erzeugen.
Ich habe das Beispielprogramm entsprechend erweitert, jedoch kann ich für das zweite Gerät den Klassennamen nicht zuweisen. In den IVI-COM Objekten wird automatisch der Name „agilentU235xClass“ vergeben. Für das zweite Gerät habe ich aber die globale Variable „agilentU235xClass1“ vergeben.
In dieser Konfiguration erscheint dann beim Programmstart die entsprechende Fehlermeldung (siehe Screenshots).
Hat jemand Erfahrung mit dieser Konfiguration bzw. weiß jemand wie ich zwei gleiche Geräte innerhalb eines Programms mit dem gleichen IVI_COM Treiber konfigurieren und ansprechen kann?
Schonmal Danke!
Gruß
Bobby


Konfiguration:
Windows XP
Vee Pro 9.2
I/O Libs 16


Angehängte Datei(en) Thumbnail(s)
       
Diese Nachricht in einer Antwort zitieren
26.11.2010, 12:02
Beitrag: #2
RE: Zwei Agilent U2355A über IVI-COM Treiber?
Hallo,

das Problem hat sich schnell von selbst gelöst.
Man muss nur den Objektnamen der IVI-COM Box ändern um den zugewiesenen global deklarierten Variablennamen benutzen zu können.
(siehe Bild)

:-)

Gruß
Andre


Angehängte Datei(en) Thumbnail(s)
   
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Gehe zu:




Partnerforen: LabVIEWForum.de| DIAdem-Forum.de| Machine-Vision-Forum.de| goMatlab.de| VEEforum.de